JOSE(1)   JOSE(1) نام (NAME) jose - مجموعه‌ابزار برای انجام امضا و رمزنگاری اشیاء JSON خلاصه دستور (SYNOPSIS) jose alg [-k KIND] jose b64 dec -i B64 [-O BIN] jose b64 enc -I BIN [-o B64] jose jwe dec -i JWE [-I CT] -k JWK [-p] [-O PT] jose jwe enc [-i JWE] -I PT -k JWK [-p] [-r RCP] [-o JWE] [-O CT] [-c] jose jwe fmt -i JWE [-I CT] [-o JWE] [-O CT] [-c] jose jwk exc [-i JWK] -l JWK -r JWK [-o JWK] jose jwk gen -i JWK [-o JWK] jose jwk pub -i JWK [-o JWK] jose jwk thp -i JWK [-a ALG] [-o THP] jose jwk use -i JWK [-a] [-r] -u OP jose jws fmt -i JWS [-I PAY] [-o JWS] [-O PAY] [-c] jose jws sig [-i JWS] [-I PAY] [-s SIG] -k JWK [-o JWS] [-O PAY] [-c] jose jws ver -i JWS [-I PAY] -k JWK [-O PAY] [-a] نمای کلی (OVERVIEW) ابزار José یک پیاده‌سازی به زبان C از استانداردهای Javascript Object Signing and Encryption است. به طور ویژه، José پیاده‌سازی استانداردهای زیر را هدف قرار می‌دهد: • RFC 7515 - امضای وب JSON (JWS) • RFC 7516 - رمزنگاری وب JSON (JWE) • RFC 7517 - کلید وب JSON (JWK) • RFC 7518 - الگوریتم‌های وب JSON (JWA) • RFC 7519 - توکن وب JSON (JWT) • RFC 7520 - مثال‌های محافظت از محتوا با استفاده از JOSE • RFC 7638 - اثر انگشت کلید وب JSON (JWK) ابزار خط فرمان José امکاناتی برای موارد زیر فراهم می‌کند: • کدگذاری و کدگشایی Base64 امن برای نشانی وب (URL-safe) • تولید و مدیریت کلید • رمزنگاری و رمزگشایی • امضا و اعتبارسنجی نویسندگان (AUTHORS) Nathaniel McCallum همچنین ببینید (SEE ALSO) jose-alg(1), jose-b64-dec(1), jose-b64-enc(1), jose-jwe-dec(1), jose-jwe-enc(1), jose-jwe-fmt(1), jose-jwk-exc(1), jose-jwk-gen(1), jose-jwk-pub(1), jose-jwk-thp(1), jose-jwk-use(1), jose-jws-fmt(1), jose-jws-sig(1), jose-jws-ver(1)   06/09/2026 JOSE(1)